Java naming convention for boolean variable names: writerEnabled vs writerIsEnabled(布尔变量名称的 Java 命名约定:writerEnabled 与 writerIsEnabled)
问题描述
以下哪些声明符合 Java 的命名约定?
Which of the following declarations conforms to Java's naming conventions?
private boolean writerIsEnabled;
// with methods like
public boolean getWriterIsEnabled()
public void setWriterIsEnabled()
或
private boolean writerEnabled;
// with methods like
public boolean getWriterEnabled()
public void setWriterEnabled()
我个人认为名字writerIsEnabled"更具可读性,尤其是当您在这样的 if 语句中使用它时 -
I personally find the first name "writerIsEnabled" to be more readable, especially when you use it in an if statement like this -
if(writerIsEnabled)
{
//...
}
推荐答案
据我所知是这样的:
private boolean writerEnabled;
// with methods like
public boolean isWriterEnabled();
public void setWriterEnabled(boolean enabled);
无论类型是boolean
还是Boolean
,区别在于Getter以is
开头,而不是get代码>.
Either when the type is boolean
or Boolean
, the difference is that the Getter starts with is
instead of get
.
我个人更喜欢 isWriterEnabled
方法.例如,像 JSF 这样的技术在访问属性时尊重该标准.EL 表达式用 is
和 get
确认.
Personally I prefer the isWriterEnabled
approach. Technologies like, for example, JSF respect that standard when accessing properties. The EL expressions are acknowledged with is
and get
.
这篇关于布尔变量名称的 Java 命名约定:writerEnabled 与 writerIsEnabled的文章就介绍到这了,希望我们推荐的答案对大家有所帮助,也希望大家多多支持编程学习网!
本文标题为:布尔变量名称的 Java 命名约定:writerEnabled 与 writerIsEnabled
基础教程推荐
- 设置 bean 时出现 Nullpointerexception 2022-01-01
- 在 Libgdx 中处理屏幕的正确方法 2022-01-01
- 如何使用 Java 创建 X509 证书? 2022-01-01
- FirebaseListAdapter 不推送聊天应用程序的单个项目 - Firebase-Ui 3.1 2022-01-01
- Java Keytool 导入证书后出错,"keytool error: java.io.FileNotFoundException &拒绝访问" 2022-01-01
- “未找到匹配项"使用 matcher 的 group 方法时 2022-01-01
- 无法使用修饰符“public final"访问 java.util.Ha 2022-01-01
- Java:带有char数组的println给出乱码 2022-01-01
- 降序排序:Java Map 2022-01-01
- 减少 JVM 暂停时间 >1 秒使用 UseConcMarkSweepGC 2022-01-01